【Laravel6】laravel/uiをインストールして、composer updateをするとエラーになったときの対処法

Laravel

スポンサーリンク

composer require laravel/ui

を打って、composer.lockにも変更を反映させたくて、

composer update

を実行すると、下みたいな感じになってエラーがでる。

Your requirements could not be resolved to an installable set of packages.

composer.jsonを見ると

"laravel/ui": "^2.0"

が追加されていた。

調べると、laravel/uiの2.0はLaravel7から使えるようで、

私が使っているのはLaravel6なので使えないからだった。

composer.jsonの「"laravel/ui": “^2.0″」→「"laravel/ui": “^1.0″」にして「composer update」をすると無事にcomposer.lockが更新された。

スポンサーリンク

Laravel

Posted by ton